Degraded Performance Of ARC Services

Incident Report for IT Service

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 15:34 BST

Investigating

We are aware of an issue with accessing and using ARC today, specifically with accessing POW.

ARC have been made aware of this issue and are working to resolve it as soon as possible, further updates will be added to this incident as we are made aware of them by ARC.
Posted Aug 19, 2025 - 14:00 BST
This incident affected: Systems (ARC Placement Management Solution).