Disruption to ARC University Placement System | Placements on Web
Incident Report for IT Service
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2024 - 12:55 BST
Investigating
We have received reports that students are experiencing further disruption accessing the Placements on the Web (PoW) component of the ARC placement management system. This is used for viewing allocations, recording skills and placement hours, and for timesheet approval.

The University has contacted the supplier of this system requesting detail on when a fix will be implemented.
Posted Oct 24, 2024 - 10:49 BST
This incident affects: Systems (ARC Placement Management Solution).