University of Worcester Main Website
Incident Report for IT Service
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 14:52 BST
Investigating
We are currently aware of a number of errors appearing on the main University of Worcester website causing large parts of the website to be inaccessible. This has been referred to our third party provider.
Posted Apr 08, 2024 - 14:45 BST
This incident affected: Systems (University Website).