Disruption to SITS/SOLE student records system

Incident Report for IT Service

Monitoring

Registration via SOLE is now possible. We are continuing to monitor the services related to this issue.
Posted Aug 14, 2026 - 10:37 BST

Investigating

We are aware of disruption to staff and students accessing and using SITS and SOLE and student registration is temporarily unavailable due to a technical issue. We are currently investigating this and will update this post either once the issue is resolved or more is known about the cause.

A redirect holding/comfort message has been placed on the SOLE/SITS page to advise users.
Posted Aug 13, 2026 - 15:45 BST
This incident affects: Systems & Infrastructure (SOLE, SITS).