Disruption to University Staff and Student Portals (MyDay)

Incident Report for IT Service

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 17:29 BST

Monitoring

A fix has been implemented by our supplier and we are monitoring the results.
Posted Jun 03, 2026 - 13:49 BST

Investigating

We have been made aware of disruption to accessing the University's staff and student online portals which run from the MyDay system.

Some users are seeing the pages hang whilst initially loading.

Whilst we investigate this incident with our supplier, you can use the following manual links to access various University online resources until this issue is resolved:

•  SOLE: https://sole.worc.ac.uk/urd/sits.urd/run/siw_sso.saml
•  Microsoft 365 Portal: https://m365.cloud.microsoft/apps
•  Blackboard VLE: https://worcesterbb.blackboard.com/ultra
•  Digital Services Website: www.worc.ac.uk/it
•  iTrent HR System: https://ce0816li.webitrent.com/ce0816li_ess/ess/dist/
•  Archibus Estates Portal: https://uwsso.asc-hs.com/archibus/login.axvw
•  Library Services: https://library.worc.ac.uk/
•     Student Timetables: https://mytimetable.worc.ac.uk
Posted Jun 03, 2026 - 13:04 BST
This incident affected: Systems & Infrastructure (MyDay).