Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 15, 2026 - 07:00 GMT
Scheduled
We will be completing a fourth set of network infrastructure upgrade works on Sunday 15th March between 07:00-09:00, following on from those completed over previous weeks.
These works will take place in the Hines, Edward Elgar, Sports Centre, Peirson and Sheila Scott buildings on the St Johns campus, in the Riverside building on Severn Campus, and in the Hive on City Campus.
These works are routine but will cause outages to all services that utilise connections to the University network and wider internet, for approximately 20 minutes in each affected building.
Networks in some University's residences will also be partially affected however these works will NOT disrupt connections to the University's Glide internet service.
Posted Mar 10, 2026 - 15:57 GMT
This scheduled maintenance affected: Wireless Networks (eduroam, UW Guest, Corporate@UW) and Wired Network (St Johns Network, City Campus Network, Hive University Network, Severn Campus Network, Clarion 3rd Party Wired Network Connections).