Outage to Card Exchange System (ID Card Issue/printing)

Incident Report for IT Service

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 16:43 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2026 - 16:02 BST

Investigating

We are aware of reported issues with the Card Exchange system affecting all activities that use it including University ID card printing for staff and students.

We are investigating the issue with our supplier and will update this post as the situation changes or is resolved.
Posted Jul 01, 2026 - 13:07 BST
This incident affected: Systems & Infrastructure (Card Exchange ID Card System).