Outage to Turnitin

Incident Report for IT Service

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 09:22 GMT

Identified

We've received reports of disruption to using the Turnitin assessment plagiarism checker used in the submission of some University assignments.

This has been confirmed by Turnitin's own status page found here (https://turnitin.statuspage.io/).

This services operates in the cloud and falls outside of the University's direct control but you can follow their page above for further updates regarding their timescales for restoring this service to normal function.
Posted Mar 11, 2026 - 17:01 GMT
This incident affected: Systems & Infrastructure (Turnitin).