Intermittent Disruption | Staff access to Stand ID card photo upload tool

Incident Report for IT Service

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 10:31 BST

Investigating

We are aware of an issue affecting staff access to card.worc.ac.uk to use Stand, the University's ID card photo upload tool. When attempting to access the page, some staff are receiving a Card Exchange branded screen but with no way to proceed to use the Stand application.

We are working with our supplier Card Exchange to resolve this issue and will update this post once a fix is identified and the issue is resolved.
Posted Sep 10, 2025 - 11:48 BST
This incident affected: Systems (Card Exchange ID Card System, Stand ID Card Photo Upload Tool).