Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 14, 2026 - 08:00 GMT
Scheduled
As part of Digital Services maintenance weekend operations, Microsoft Windows updates and other security patching will be applied to servers across the University estate, including those that allow network access control to function.
During the weekend, 20-30 minute outages to University services and guest devices reliant on wired and wireless connections to the University network and wider internet are possible. Disruption is most likely to affect new devices connecting to the network and guest users, who may have trouble logging in during the maintenance window.
Whilst we cannot guarantee exactly when outages could occur, every effort will be made to limit them and buildings such as the University Arena hosting events scheduled in the University calendar will be protected.
Posted Mar 10, 2026 - 16:09 GMT
This scheduled maintenance affected: Wired Network (University connection: Internet (Janet), St Johns Network, City Campus Network, Hive University Network, Severn Campus Network, Lakeside Network, Clarion 3rd Party Wired Network Connections) and Wireless Networks (eduroam, UW Guest, Corporate@UW, Clarion 3rd Party Wireless Network Connections).