Monitoring disruption to University systems reliant on Amazon Web Services | Blackboard, Turnitin etc

Incident Report for IT Service

Monitoring

The University has been experiencing issues with a number of its systems that are reliant on Amazon Web Services (AWS) to function. This includes Blackboard integrations, including Turnitin, Collaborate and Talis Aspire, where attempting to access the LTI links on Blackboard returns an error.

The outage to AWS is nationwide across the UK affecting a broad number of major retailers, banks, technology infrastructure companies and other businesses.

We are seeing signs that AWS is beginning to recover from this outage (the status page for example is powered by AWS) but we will continue to monitor the incident and any updates provided from AWS. We update this post if the situation changes further.
Posted Oct 20, 2025 - 11:41 BST
This incident affects: Systems (Blackboard, Turnitin, Talis Aspire).