Disruption to Accessing University MyDay Portals
Incident Report for IT Service
Monitoring
Our cloud service provider myday have report that stability in their systems have now improved and are closely monitor performance and address any potential issues that may arise.
Posted Oct 22, 2024 - 13:28 BST
Investigating
We are currently aware of distribution access the Student & Staff MyDay Portal. You may find the portal running slowly or being unable to access certain areas.

You can access Blackboard via this direct link and select 'University SSO Login' from the drop down box: https://worcesterbb.blackboard.com/
Posted Oct 21, 2024 - 11:59 BST
This incident affects: Systems (Staff Homepage, MyDay).