Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 22, 2026 - 07:00 GMT
Scheduled
We will be completing a fifth set of network infrastructure upgrade works on Sunday 22nd March between 07:00-11:00, following on from those completed over previous weeks.
These works will take place in the Edward Elgar, Charles Darwin and Sports Centre buildings on the St Johns Campus, in the University Arena on Severn Campus, and in the Hive and the Art House on City Campus.
These works are routine but will cause outages to all services that utilise connections to the University network and wider internet, for approximately 20 minutes in each affected building.
Posted Mar 17, 2026 - 16:09 GMT
This scheduled maintenance affected: Wireless Networks (eduroam, UW Guest, Corporate@UW, Clarion 3rd Party Wireless Network Connections) and Wired Network (St Johns Network, City Campus Network, Hive University Network, Severn Campus Network, Clarion 3rd Party Wired Network Connections).