Intermittent disruption to accessing MyDay
Incident Report for IT Service
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 08:50 BST
Investigating
Staff, students, and applicants accessing the University's MyDay pages are currently receiving either an error message when attempting to login or the page is simply not loading and timing out.

We are looking into this and will update this page once further updates become available.
Posted Apr 10, 2024 - 17:07 BST
This incident affected: Systems (MyDay).