Outage to Archibus System

Incident Report for IT Service

Resolved

The provider SWG has confirmed that Archibus is now working as intended.
Posted Aug 07, 2026 - 13:31 BST

Investigating

We are currently investigating an outage to the University Facilities System (Archibus). The system is currently inaccessible and we are working with our supplier to identify the cause of the issue. Updates to follow as they become available.
Posted Aug 07, 2026 - 10:32 BST